Fertility Friends Support Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
4,394 Posts
Discussion Starter · #1 ·
I was wondering if anyone can help.

I am mid cycle at the mo and I am not on any tx ... my last round of icsi was July of the this year.

I have noticed last night and this morning I have brown blood when I go to the loo ... sorry if this is TMI, but it is only when I wipe myself.

I have no pain whatsoever ... in fact I was shocked to see the blood ... and I am not prone to bleed mid-cycle ... I know some women do, but I have never bleed mid cycle.

Is this something I should be concerned about?

Pls can you let me know .... Belinda x :(
 

·
Premium Member
Joined
·
1,306 Posts
Hi There,

Any chance it could be ovulation bleeding? Not knowing your history this maybe a really pants thing to say, if so sorry.
Can you call your clinic or GP for advise?

Hope all goes well and good luck.

Charlie
 

·
Premium Member
Joined
·
9,037 Posts
Hi there,
Not a nurse but thought I'd pop on and add my say!
I am cd13, and am pretty sure I ovulated yesterday.  (Just through my own observations!)  Today, I have been getting brown spotting, only really when I wipe (ok, FAR TMI!!) 
I never usually get this, I had ICSI in July, and FET last month. 
A good friend of mine had ICSI back in June, and has had ovulation spotting monthly since, apparently this can happen after a big event, such a EC/ET, birth etc. 
Hope that helps you some,
Marie xx
 

·
Premium Member
Joined
·
4,394 Posts
Discussion Starter · #4 ·
Thanks Charlie and Marie ... I had never heard of this before!

I will monitor it rather than worry too much!

Thanks again ... Belinda x
 
1 - 4 of 4 Posts
Top