Fertility Friends Support Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi all

I'm new here and just wondered if any of you ladies could offer any advice. this will be our 4th ivf cycle all the rest ending in negative.
i am 13days post egg collection and 11day post embryo transfer i had 2 top grade embryos transfered a 9 cell and a 7cell. never had grade 1s before only grade 3s, yesterday when i woke i had a brown discharge like stuff ( sorry for the over share) but it soon went away and i had it again this morning, never experienced anything like this before. phoned clinic but not very helpful just told me to carry on with the pessaries and test as normal on sat 4th dec. the the question i need answering is could this be a sign my period is on the way? in my normal cycle i tend to just have red flow straight away so found this brown stuff very strange

Thank you
 

·
Registered
Joined
·
11 Posts
Hi floss

This is a bit bizarre, but I just logged on to ask essentially the same question! I'm afraid I don't really have any helpful answers, but I'm on ovulation injections at the moment and also had brown discharge 7 days after I ovulated ... I read that implantation bleeding can happen around this time and only lasts a day or two. I don't know if this is what we've had (I'm trying not get my hopes up), but it is certainly different from the other four cycles (all negative). I guess it could also be the lining beginning to come away, but it hasn't continued beyond those two days. Hhhmmmm.

I called my clinic too and they basically said they couldn't really tell me what it was and just to test on sat 4th as well. So I'm sorry I can't provide anything terribly helpful, but I'll keep everything crossed for you and send happy thoughts for saturday!

A xx
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top