Fertility Friends Support Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
44 Posts
hi

i had bleeding on day 9 of my 2ww and currently on day 11.  it was a brown discharge and carried on for two days.  my clinic advised me to up the dose of cyclogest and since than the bleeding has subsided.  They said this could be implantation bleeding... i was told to take complete bed rest as i was also getting cramping at the same time...
try not to worry, i know its easier said than done as i too was convinced it was all over. i test on the 10th of May and am praying to god to add this special blessing into my life... i'll pray for you too.  take care hon and i hope it all works out.

 

·
Premium Member
Joined
·
508 Posts
Hi there :)

I bled on day 11 of my first IVF, which was black, then brown then heavy red and clotty. it lasted 2 days only, but the result was negative.

This cycle I started spotting on day 7. I was told it could be an implantation bleed as I had a scan and everything looked fine, and didn't show that AF was imminent.
7 days later I'm still bleeding! I haven't had a proper AF, but think the progesterone may have been holding back the flood, but did test ^BFN^ this morning.

I would love to know why I bled so early on too, not sure if it's due to a very efficient body flushing out inviable embryo's, or problems with immune system rejecting them :-\

Take Care, and remember it can be an implantation bleed :)
luv nat xx
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top