Fertility Friends Support Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
790 Posts
Discussion Starter · #1 ·
Hi to everyone !
I started down regging on Feb. 28th and need to go for a scan on the 23rd March.  I am worried that maybe the drugs aren't working for me!!  I am having daily injections and am suffering NO side effects at all.  The only symptoms I am having are similar to the discharge I get before I ovulate.  Is this normal ???  I've tried ringing the clinic but can only get the answer phone ?!  Any help would be appreciated.
 

·
Registered
Joined
·
520 Posts
Hi Hollysox,

I too was in a state of panic whilst downregging. I had to sniff  rather then inject and many a time i did a teeny extra sniff...just incase i hadn't sniffed enough the first time!!

I read about so many side effects but i didn't have any! I too had extra c.m. and think i had one headache day after starting sniffing.

The only other difference was that when my period came it came with a vengeance!! Really painful! :mad:

I think you only know that the drugs are working if you have a withdrawal bleed then at the actual scan or bloodtest!

Good luck

Hope my answer has helped a little bit!

Emmak

 

·
Registered
Joined
·
790 Posts
Discussion Starter · #3 ·
Thanks for answering me Emma ! You've helped put my mind at ease knowing that you also suffered no side effects of the drugs but for extra c.m ?!  I'm not sure if I'm looking forward to my next af now though !!

Thanks again for your help !  :)

 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top