Fertility Friends Support Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Hi  ^help^

Can anyone help? I had FET yesterday with two 5 cell embryo's. I thought it would be way too early for any symptoms but I have been suffering with the worst headache all afternoon  :mad:. Has anyone else experienced this?

Any advice would be great.
Thanks xx
 

·
Premium Member
Joined
·
17,093 Posts
Hi

Are you on any medication such as progesterone or oestrogen, because if so, this could be causing symptoms such as headache.  It is safe to take paracetamol but not anything that contains ibuprofen.  Perhaps it's a stress headache ?

If you only had ET yesterday of 5 cell embies then it is very early days yet.  I'm presuming your embies were 2 days old if 5 cells and only once embies have reached blasto stage at 5 days old will they be ready to start implanting...and only once HCG has been released from implanting embie will you possibly start to get any pregnancy like symptoms.

Good luck
Natasha
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #3 ·
Hi Minxy,

Yes you're right the embryo's were only two days old. I think you're right again when you said it might be a stress headache as I'm not on any medication at all.

Went out for dinner with DH and the pain has subsided now!

Thanks for replying. xx
 

·
Premium Member
Joined
·
17,093 Posts
Glad your headaches eased up.....just make sure you keep your fluids up, even though you're not on any meds it's still a good idea to drink plenty as this keeps you hydrated, which can obviously be another cause of headches.

Are you not on any cyclogest through 2ww ?

Good luck
Natasha
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #5 ·
Hi Minxy

Nope no cyclogest. No Drugs at all.

I am dinking water as I write (promise!) xx
 
1 - 5 of 5 Posts
Top