Fertility Friends Support Forum banner
1 - 4 of 4 Posts

·
Premium Member
Joined
·
9,037 Posts
Discussion Starter · #1 ·
Hello,
me again! ;D
I have just been to the toilet (TMI) AND HAVE NOTICED LOADS OF ewcm. Its quite creamy, and for the first time since starting stims (day 4 of stims) I can actually 'feel' my ovaries.
Is it normal to have ewcm this early on? I'm not due for my first scan until monday, and EC is week of 2nd august! :eek:
Marie xx
 

·
Registered
Joined
·
104 Posts
;) Hi Marie (fellow rainbower)

I've got this too!!!!!!!!!!!!!!!!!

I mentioned it on thursday at my clinic & the nurse said not to worry, it's just a sign of rising oestrogen levels & is good news!

I've also started to 'feel' my ovaries on about day 5-6 of stimms. I'm sure you've got lots of follies growing!!!!!!!!

Love P XXXXXXXXXXXXXXXXXXXXXX
 

·
Registered
Joined
·
1,035 Posts
^daisy^

What is ewcm? ^dunce^ I am day 3 timms,and not noticed anything!!!

good luck you two,xxx
 

·
Premium Member
Joined
·
9,037 Posts
Discussion Starter · #4 ·
mmmbop, ewcm is egg white cervical mucus, which is 'fertile' mucus. It looks like (uncooked!) egg white.
I didnt feel anything yesterday either. Its only this evening that I have felt vague aches in my ovaries.

Pocahontas, my fellow rainbower! I havtn felt anything all day, so it came as a bit of a shock to actually 'feel' my ovaries tonight. Its not there all the time, I guess it will get more and more over the next few days. Thanks for the info - I panicked and thought I was going to ovulate!! ^chuckle^

Marie xx
 
1 - 4 of 4 Posts
Top