Fertility Friends Support Forum banner
1 - 8 of 8 Posts

·
Premium Member
Joined
·
17,093 Posts
Discussion Starter · #1 ·
Hi
This is the first time I've posted here so please bare with me....
We've been ttc for over a year (I'm 36 - just & boyfriends nearly 30).   I've endo (diagnosed at 1st lap when 19), adhesions, bicornuate uterus, sluggish & damaged tubes etc - last op for endo/adhesions was May 2004.  We're currently seeking fertility treatment - had our 1st appt last week.  We had some tests done privately last year when I saw my private gynae about endo/fertility (BT's for me, sperm for boyfriend ) & all ok but our NHS fertility consultant wants us to have more done which is fine & we're in the process of doing this.   :p
However, I usually have a very regular 28 day cycle but this month I was 9/10 days late (came on during night so not sure of exact time so that's why I put 9/10 days !).  Obviously I'd got my hopes up as never been late before....but unfortunately I came on.  :'(  Now, it was really really heavy & very dark red blood with big clots (sorry to be so graphic  :-[  :-[ ) & I had major cramps & lower back ache.  I've not suffered badly from period pains/problems since my last op for endo/adhesions last year when I also had a LUNA.  It just seemed really strange for me to be late & then for it to be like this..... my friend suggested that perhaps I did get pregnant (so to speak) in that the egg was fertilised but that it didn't embed properly so that was why I came on late & then had/having such a bad one this month.  I've no idea if this could be true or whether she/we are just clutching at straws in trying to find an explaination.  :-\ Whatever the reason I'm been feeling pretty down about it as I wish I knew why my body was playing these cruel tricks on me.
Could you perhaps give me some advice as to why I was possibly so late when never usually ?  :-\  ???
Many thanks
Natasha
 

·
Registered
Joined
·
371 Posts
Natasha

I am not a nurse but from what you describe I would say that your friend's explanation is the most likely. Sorry I can't be of more help and best of luck with getting pregnant

Hugs
Megan
 

·
Registered
Joined
·
2,229 Posts
I would agree that your friends suggestion does make sense. If you get another period like it then I may be more tempted to be concerned that the endo is causing the horrible periods.

Ruth
 

·
Registered
Joined
·
930 Posts
Hi Natasha

I'm afraid I can't really directly help with your question - but I just wanted to offer you some hope.  I also have endo and was advised not to expect much success in ttc.

But the good news for me is that I have been successful - and natually!

I hope this message offers a glimmer of light for you.
Best of luck
DC
xx
 

·
Premium Member
Joined
·
17,093 Posts
Discussion Starter · #5 ·
Thanks so much for your replies....it's really appreciated.  Went for 1st set of BT's this morning (day 5 of cycle) for LH, FSH, Thyroid (& Rubella  ??).  Had LH & FSH done about 6mths ago & was ok but now we've had 1st appt with fertility consultant he wants us to have more done.....next on day 21 - progesterone....so hoping all ok still !
Anyway, thanks again & lots of luck to everyone ttc....
Take care
Natasha
 

·
Registered
Joined
·
166 Posts
HI there just thought I would add some comments.

What you have described happened to me a couple of times - on one occassions I felt that my whole womb had given way in one go due to the amount of blood loss.

When I asked the cons what was going on he more or less said that I could've been pg but because no test had been done it was hard to tell.  If this happens again do do a test as it is the only way you will know for certain.

At the end of the I was finally diagnosed with an over-active thyroid and heavy bleeds is one sympton so glad to see the thyroid is also a test being done on you.

Good luck with your tx in any event.

barbara
 

·
Premium Member
Joined
·
17,093 Posts
Discussion Starter · #7 ·
Hi Barbara
Thanks for your reply.....I had thyroid BT with other BT's 6 mths ago & all was ok then (although didn't have Rubella tested then)....I've not had heavy painful bleeds since my last op for endo/adhesions last May & it was a bit of a shock to be late & then having them so bad this month (I had LUNA at last op too & not suffered pain since...until now).....I did do some pg tests as never usually late - they were -ve but my fertilty cons. suggested that it may have been too early or since I've higher risk of ectopic that this can sometimes cause lower levels of hcg so can produce false -ve's.....my GP sent me for a pg BT last Friday but the results not back yet....and obviously even if I was then I've now come on so know I'm not now  :'(

Anyway, thanks again...really appreciate your comments & kind message
Take care
Natasha
 

·
Registered
Joined
·
4,185 Posts
Hi Minxy,

Nice to see you over here   :-X 
I just wanted to add that I think it is a possiblity that you did get pg and it didn't embed properly so came away again. I was thinking that is what may have happened with me last month when I came on 4/5 days early!  ???
At least if it was an ectopic pg it was a good thing that didnt hang on.

All the very best this month.  Jo xx

PS. didnt realise you had a toy boy - lucky you  :p  :)
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top